‘xyz’ conflicts with the name of a preexisting python module

I have succesfully started a Django CMS project by hand. However, whenever I try to use the Installer, it fails. I’m on a windows 10 machine. I have Python 3.8.3 installed which seems to match the requirements as mentioned in the documentation. However, whenever I try to run the installer no matter in which mode it exits with saying that ‘xyz’ conflicts with the name of a preexisting python module. However I tried a bunch of different names that definitely are not python modules. I have found people asking about this on stackoverflow but with no suitable answer.
Any suggestions are appreciated.

@Spiff can you have a look at this issue https://github.com/nephila/djangocms-installer/issues/359 with similar issues from other users and some way to check possible source for errors

1 Like

I noticed that the poster in your link was using a newer version of python. I upgraded python and followed his instructions and now it worked. Thanks!

1 Like

:smiley: :tada: great to hear!