Unable to make icons visible in editor

Greetings, I’m having trouble making icons appear in Ckeditor.
I’m able to render font avesome 5 icons on website by including their CDN in template, now according to djangocms-icon

  1. You need to make sure your icon CSS is passed via CKEditors contentsCss parameter.
  2. CKEditor automatically removes empty tags, you can prevent this by adding a javascript configuration file to style_set.

I’ve included settings to my project the same way as shown in https://github.com/divio/django-cms-demo/blob/master/src/settings.py#L229

CKEDITOR_SETTINGS = {
‘stylesSet’: ‘default:/static/js/addons/ckeditor.wysiwyg.js’,
‘contentsCss’: [’/static/css/base.css’],
}

and populated both paths, stylesSet file containing the example from the same repository, now I’m not sure how to populate base.css file, or how to pass css with icons to contentCss in general. I’ve tried include font awesome 5 icons in base.css file with @include url(…) with url of the same cdn path I’m using in template but that appears to have no effect since the icons are still shown as invisible character in editor.

hi @Hydridity

You can have a look at our djangocms-template code where the djangocms-icon package works out of the box: https://github.com/django-cms/djangocms-template