First steps and publication doesn't work

First steps and publication doesn’t work.

After a good 20 years with PHP, I now want to get used to Django-CMS.

I have it running in a Docker as well as locally.

Can create pages and edit blocks but when publishing there is always a dialog where you can’t read anything and which disappears after a few seconds.

What can that be? As a newbie I’m on the line and can’t find anything in the step-by-step instructions.

1 Like

Welcome to django cms :slight_smile: if you’re running 3.8 then this could be the reason: . Django-treebeard 4.5.1 9

My Python version is 3.9.5 and I haven’t installed another one either.

I just tried again. I only install the Django-cms-installer with pip and then do the migration of the database and the superuser.

As I said, my Python is 3.9.5

how do i get this error out?

Okay, I have now checked it several times differently and now I see the 500 error in the console with what was linked above.

| treebeard.exceptions.NodeAlreadySaved: Attempted to add a tree node that is already in the database
web_1 | [30/May/2021 10:17:44] “POST /admin/cms/page/1/de/publish/ HTTP/1.1” 500 116312

What do I probably have to change in the Requirements.txt “I suspect older version or” in order to no longer have the error?

Okay through another forum I found it.

in Requirements.txt I have the line
django-treebeard> = 4.0, <5.0 changed to
django-treebeard == 4.4

Now it works!